The Fair Organ Preservation Society Discussion Forum
http://www.fops.org/forum/

Browser 'back' button issues...
http://www.fops.org/forum/viewtopic.php?f=11&t=73
Page 1 of 1

Author:  Dave Stubbs [ Thu Dec 24, 2009 10:51 am ]
Post subject:  Browser 'back' button issues...

:bug2: There are a number of situations where using your Internet browser 'back' button may display a page expiry message;

In Internet Explorer you receive this message first:

resend_ie.gif
resend_ie.gif [ 5.27 KiB | Viewed 4829 times ]

...followed by this message when you refresh the page:

resend_ieretry.gif
resend_ieretry.gif [ 7.16 KiB | Viewed 4829 times ]


Firefox seems to function correctly, except for certain conditions where you will receive the message:

resend_firefox.gif
resend_firefox.gif [ 9.62 KiB | Viewed 4829 times ]


This is a safety feature built in to Internet browsers to stop you from resending data, for example on a shopping site, where you could end up with a duplicated purchase if you go back to the payment page!

Unfortunately the new forum software also triggers this sometimes if you go back after submitting a new post, or another example is when you place a web link in your post and test the link in a preview, you will be prompted to refresh/resubmit when you click on the back button to return to the post editor.

Once resubmitted, your post will be restored, then the back button will function without any prompts.

I am working on a solution, but in the meantime you will have to continue refreshing/resubmitting when requested.

You could try using Firefox, as Internet Explorer seems to have stricter rules relating to this problem.

Page 1 of 1 All times are UTC
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/