The Fair Organ Preservation Society Discussion Forum
http://www.fops.org/forum/

Standard fault with organs!
http://www.fops.org/forum/viewtopic.php?f=8&t=162
Page 1 of 1

Author:  Dave Stubbs [ Sun May 02, 2010 5:24 pm ]
Post subject:  Standard fault with organs!

I have been out with the ex-Stuart Marti-Bowler Dean organ, which now belongs to George Houghton and I noticed that it was beginning to sound rather wheezy!

So I assumed it was a lack of air and first checked that the blower intake didn't have something stuck on it...couldn't see anything.

So I checked for air leaks..there didn't seem to be any more than usual!

Then I had a closer look at the blower air intake filter...oops...slapped wrists...no wonder the poor organ sounded out of breath...this shows the amount of dirt that would have been passed through the organ without a filter...!

File comment: The blower air intake filter...oops, should have cleaned that before!
IMG_0337a.jpg
IMG_0337a.jpg [ 68.16 KiB | Viewed 5303 times ]


File comment: The blower filter after cleaning!
IMG_0340_a.jpg
IMG_0340_a.jpg [ 64.95 KiB | Viewed 5303 times ]

Author:  George Houghton [ Sun May 02, 2010 8:38 pm ]
Post subject:  Re: Standard fault with organs!

No wonder the Organ was Wheezing, just imagine having no filter on the air intake,all that muck would be in the pipes and rather more difficult to clean.
I think that proves the point of having some sort of filter on the air intake.

Regards
George :grinder:

Author:  Dave Stubbs [ Wed May 05, 2010 9:13 am ]
Post subject:  Re: Standard fault with organs!

Hi George.

Yes, but the worrying thing is that Stuart (bless him!) never had a filter on the blower, I fitted it when I started operating the organ!

I seem to remember us cleaning the filter on your Pell organ "Piper" on a regular basis.

Page 1 of 1 All times are UTC
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/